summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/amq-protocol/amq-protocol-1.9.2.ebuild')
-rw-r--r--dev-ruby/amq-protocol/amq-protocol-1.9.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/amq-protocol/amq-protocol-1.9.2.ebuild b/dev-ruby/amq-protocol/amq-protocol-1.9.2.ebuild
new file mode 100644
index 000000000000..35040417f9c6
--- /dev/null
+++ b/dev-ruby/amq-protocol/amq-protocol-1.9.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An AMQP 0.9.1 serialization library for Ruby"
+HOMEPAGE="http://github.com/ruby-amqp/amq-protocol"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/bundler/ s:^:#:' -e '/effin_utf8/ s:^:#:' spec/spec_helper.rb || die
+}