summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/amq-protocol')
-rw-r--r--dev-ruby/amq-protocol/Manifest1
-rw-r--r--dev-ruby/amq-protocol/amq-protocol-1.9.2.ebuild26
-rw-r--r--dev-ruby/amq-protocol/metadata.xml8
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/amq-protocol/Manifest b/dev-ruby/amq-protocol/Manifest
new file mode 100644
index 000000000000..cd4d2e77a545
--- /dev/null
+++ b/dev-ruby/amq-protocol/Manifest
@@ -0,0 +1 @@
+DIST amq-protocol-1.9.2.gem 43520 SHA256 79e018cb1a3522967525973ae04d40884620e8d4adca02afeb710f00643a84be SHA512 ea4553b337589589cc89b70e351722ec8af402bd560d73fd35ad41665424a6212e03e26ac86aace5d90f599c7fc2236686fbd83bd75c7023647d95163a2d8573 WHIRLPOOL 5fcfd806b8d84aa64b10bc160fe439dcdff2977b739e04ec23b8f86d94f7a5bee4b95d3688317096b0dcf9214a12921f4b0a4c93c9bd0f6ad3376a6199659189
diff --git a/dev-ruby/amq-protocol/amq-protocol-1.9.2.ebuild b/dev-ruby/amq-protocol/amq-protocol-1.9.2.ebuild
new file mode 100644
index 000000000000..35040417f9c6
--- /dev/null
+++ b/dev-ruby/amq-protocol/amq-protocol-1.9.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An AMQP 0.9.1 serialization library for Ruby"
+HOMEPAGE="http://github.com/ruby-amqp/amq-protocol"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/bundler/ s:^:#:' -e '/effin_utf8/ s:^:#:' spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/amq-protocol/metadata.xml b/dev-ruby/amq-protocol/metadata.xml
new file mode 100644
index 000000000000..b682934d3016
--- /dev/null
+++ b/dev-ruby/amq-protocol/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">ruby-amqp/amq-protocol</remote-id>
+ </upstream>
+</pkgmetadata>