summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/cocaine-core')
-rw-r--r--net-misc/cocaine-core/Manifest3
-rw-r--r--net-misc/cocaine-core/cocaine-core-0.11.2.5.ebuild25
-rw-r--r--net-misc/cocaine-core/cocaine-core-0.11.3.2.ebuild25
-rw-r--r--net-misc/cocaine-core/cocaine-core-0.9.2-r1.ebuild25
-rw-r--r--net-misc/cocaine-core/files/cocaine-core-0.11.2.5_binutils-2.23-compat.patch19
-rw-r--r--net-misc/cocaine-core/files/cocaine-core-0.9.2-boost-1.53.patch13
-rw-r--r--net-misc/cocaine-core/metadata.xml11
7 files changed, 121 insertions, 0 deletions
diff --git a/net-misc/cocaine-core/Manifest b/net-misc/cocaine-core/Manifest
new file mode 100644
index 000000000000..9158d25bf220
--- /dev/null
+++ b/net-misc/cocaine-core/Manifest
@@ -0,0 +1,3 @@
+DIST 0.9.2.tar.gz 174494 SHA256 c44d99fb3771692aa2ed8b4573954d264397c18662e05c2d95e93a5027499c8d SHA512 42bf9f38311026966b11414fc9987b4fc1d30dba9360152662810ce4e49ab1c8e662b18299efe2831b1ed7ea3490a8afb36195d7e7fc609cc9527e2c71f71bd1 WHIRLPOOL 970510d9400ca86b89fac97b5504ec6de6169bdb05819926445c8a62bf0cdc4f0166de831999f41fcf39522978acf381255d3639365142e9c4f68c9748b8e6c1
+DIST cocaine-core_0.11.2.5.tar.gz 376997 SHA256 9c55c9ab4ececf00e1f71909a30e412663d72f2c8b213c01a2dceb9c1a705cf4 SHA512 f2962d41ba12ebae475cb10d501da8d7b3ca6a428b4b2e8779dd7d768cacc2e3bf9b7952354454e432e2623a00add3d7cf424b12968c0c4a905a65dbda544866 WHIRLPOOL d82de7d5ceef66f571631ba495e2bf2169265862b52811e5aaf2d60ff915d2b5cb39b744e7c1871b28f9d4a49154e7ca914e7b84808f3e1998a73ad759632ee8
+DIST cocaine-core_0.11.3.2.tar.gz 378575 SHA256 0a350f6c7b80957258be9dafc209cf54b561fc34eae781c2fbd533c17636d13f SHA512 f0a5eea827d0fbf65c484e6068a24dd1e81dfc868f38ef829003b410783a354a58886d2db972ea24adb6075b38ceb230432555b35af4aceb0193c4a12ab874cd WHIRLPOOL d302d25f552db618ceab5c17967eb16df802d2cf16e6ae0d33a5ff6835b149f98dfe1dd91ee876b5e9e8847044179242b08aeb6b420209574219fa0b432f5783
diff --git a/net-misc/cocaine-core/cocaine-core-0.11.2.5.ebuild b/net-misc/cocaine-core/cocaine-core-0.11.2.5.ebuild
new file mode 100644
index 000000000000..63b937516bd4
--- /dev/null
+++ b/net-misc/cocaine-core/cocaine-core-0.11.2.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Cloud platform, core parts"
+HOMEPAGE="http://reverbrain.com/cocaine/"
+SRC_URI="http://repo.reverbrain.com/precise/current/source/${PN}_${PV}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/boost:=
+ <net-libs/zeromq-3
+ dev-libs/libev
+ <dev-libs/msgpack-0.6
+ dev-libs/libcgroup
+ "
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}_binutils-2.23-compat.patch" )
diff --git a/net-misc/cocaine-core/cocaine-core-0.11.3.2.ebuild b/net-misc/cocaine-core/cocaine-core-0.11.3.2.ebuild
new file mode 100644
index 000000000000..39008105d180
--- /dev/null
+++ b/net-misc/cocaine-core/cocaine-core-0.11.3.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Cloud platform, core parts"
+HOMEPAGE="http://reverbrain.com/cocaine/"
+SRC_URI="http://repo.reverbrain.com/precise/current/source/${PN}_${PV}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/boost:=
+ <net-libs/zeromq-3
+ dev-libs/libev
+ <dev-libs/msgpack-0.6
+ dev-libs/libcgroup
+ "
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.11.2.5_binutils-2.23-compat.patch" )
diff --git a/net-misc/cocaine-core/cocaine-core-0.9.2-r1.ebuild b/net-misc/cocaine-core/cocaine-core-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..f1e3295c75b1
--- /dev/null
+++ b/net-misc/cocaine-core/cocaine-core-0.9.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Cloud platform, core parts"
+HOMEPAGE="http://reverbrain.com/cocaine/"
+SRC_URI="https://github.com/cocaine/${PN}/archive/${PV}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/boost:=
+ <net-libs/zeromq-3
+ dev-libs/libev
+ dev-libs/msgpack
+ dev-libs/libcgroup
+ "
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-boost-1.53.patch" )
diff --git a/net-misc/cocaine-core/files/cocaine-core-0.11.2.5_binutils-2.23-compat.patch b/net-misc/cocaine-core/files/cocaine-core-0.11.2.5_binutils-2.23-compat.patch
new file mode 100644
index 000000000000..532700bec70b
--- /dev/null
+++ b/net-misc/cocaine-core/files/cocaine-core-0.11.2.5_binutils-2.23-compat.patch
@@ -0,0 +1,19 @@
+commit 771bc9f8055e7baf58011ff7514827b6212f9f51
+Author: Andrey Sibiryov <me@kobology.ru>
+Date: Fri Dec 6 12:51:59 2013 +0400
+
+ Added binutils 2.23 compatibility.
+
+diff --git a/config.hpp.in b/config.hpp.in
+index a73fa48..651aa3c 100644
+--- a/config.hpp.in
++++ b/config.hpp.in
+@@ -8,5 +8,8 @@
+ #define COCAINE_VERSION \
+ COCAINE_MAKE_VERSION(COCAINE_VERSION_MAJOR, COCAINE_VERSION_MINOR, COCAINE_VERSION_RELEASE)
+
++#define PACKAGE "cocaine-core"
++#define PACKAGE_VERSION COCAINE_VERSION
++
+ #cmakedefine COCAINE_DEBUG
+ #cmakedefine COCAINE_ALLOW_CGROUPS
diff --git a/net-misc/cocaine-core/files/cocaine-core-0.9.2-boost-1.53.patch b/net-misc/cocaine-core/files/cocaine-core-0.9.2-boost-1.53.patch
new file mode 100644
index 000000000000..2f03a328e0a9
--- /dev/null
+++ b/net-misc/cocaine-core/files/cocaine-core-0.9.2-boost-1.53.patch
@@ -0,0 +1,13 @@
+Nur in cocaine-core-0.9.2: build.
+Nur in cocaine-core-0.9.2/include/cocaine: config.hpp.
+diff -ru cocaine-core-0.9.2_org/include/cocaine/interfaces/storage.hpp cocaine-core-0.9.2/include/cocaine/interfaces/storage.hpp
+--- cocaine-core-0.9.2_org/include/cocaine/interfaces/storage.hpp 2012-08-29 15:54:35.000000000 +0200
++++ cocaine-core-0.9.2/include/cocaine/interfaces/storage.hpp 2014-07-29 13:49:40.130375695 +0200
+@@ -22,6 +22,7 @@
+ #define COCAINE_STORAGE_INTERFACE_HPP
+
+ #include <boost/thread/mutex.hpp>
++#include <boost/thread/lock_guard.hpp>
+ #include <boost/tuple/tuple.hpp>
+
+ #include "cocaine/common.hpp"
diff --git a/net-misc/cocaine-core/metadata.xml b/net-misc/cocaine-core/metadata.xml
new file mode 100644
index 000000000000..67ee8b27ff2a
--- /dev/null
+++ b/net-misc/cocaine-core/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">cocaine/cocaine-core</remote-id>
+ </upstream>
+</pkgmetadata>