summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/htun/files')
-rw-r--r--net-misc/htun/files/README.gentoo3
-rw-r--r--net-misc/htun/files/htun-0.9.6-glibc.patch14
-rw-r--r--net-misc/htun/files/htun-0.9.6-makefile.patch22
3 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/htun/files/README.gentoo b/net-misc/htun/files/README.gentoo
new file mode 100644
index 000000000000..1710c726723a
--- /dev/null
+++ b/net-misc/htun/files/README.gentoo
@@ -0,0 +1,3 @@
+NOTE: HTun requires the Universal TUN/TAP module
+available in the Linux kernel. Make sure you have
+compiled the tun.o driver as a module!
diff --git a/net-misc/htun/files/htun-0.9.6-glibc.patch b/net-misc/htun/files/htun-0.9.6-glibc.patch
new file mode 100644
index 000000000000..66f9b5ba00a5
--- /dev/null
+++ b/net-misc/htun/files/htun-0.9.6-glibc.patch
@@ -0,0 +1,14 @@
+get things building with glibc-2.8
+
+http://bugs.gentoo.org/248100
+
+--- include/common.h
++++ include/common.h
+@@ -23,6 +23,7 @@
+ #ifndef __COMMON_H
+ #define __COMMON_H
+
++#include <limits.h>
+ #include <netinet/in.h>
+ #include <time.h>
+ #include "queue.h"
diff --git a/net-misc/htun/files/htun-0.9.6-makefile.patch b/net-misc/htun/files/htun-0.9.6-makefile.patch
new file mode 100644
index 000000000000..0a94966802d8
--- /dev/null
+++ b/net-misc/htun/files/htun-0.9.6-makefile.patch
@@ -0,0 +1,22 @@
+--- src/Makefile 2005-10-27 12:58:53.000000000 +0200
++++ src/Makefile 2013-03-08 22:20:52.360922189 +0100
+@@ -20,16 +20,14 @@
+
+ # $Id$
+
+-
+-CFLAGS = -I../include -I. -O -W -Wall -g -D_REENTRANT #-pg -a
+-LDFLAGS = -lfl -lpthread # -flex for linux, solaris ?
+-LEX_CFLAGS = -I../include -I. -g -D_REENTRANT #-pg -a
++CFLAGS := $(CFLAGS) -I../include -I. -O -W -Wall -D_REENTRANT
++LDFLAGS := $(LDFLAGS) -lfl -lpthread
++LEX_CFLAGS = -I../include -I. -D_REENTRANT
+
+ # in Linux, LFLAGS is empty. In Solaris, LFLAGS = -lnsl -lsocket
+ #LFLAGS = -lnsl -lsocket
+
+ VPATH = .:../include
+-CC := gcc
+ LEX = flex
+ YACC = yacc
+ INCLUDE := $(wildcard ../include/*.h)