summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/infernal/files/infernal-1.0.2-respect-DESTDIR.patch')
-rw-r--r--sci-biology/infernal/files/infernal-1.0.2-respect-DESTDIR.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/sci-biology/infernal/files/infernal-1.0.2-respect-DESTDIR.patch b/sci-biology/infernal/files/infernal-1.0.2-respect-DESTDIR.patch
new file mode 100644
index 000000000000..ea465e592ffa
--- /dev/null
+++ b/sci-biology/infernal/files/infernal-1.0.2-respect-DESTDIR.patch
@@ -0,0 +1,16 @@
+Build system does not respect DESTDIR by default.
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -203,9 +203,9 @@
+ # "make install" installs the programs in BINDIR
+ #
+ install:
+- mkdir -p ${BINDIR}
++ mkdir -p $(DESTDIR)${BINDIR}
+ for file in $(PROGS); do\
+- cp src/$$file $(BINDIR)/;\
++ cp src/$$file $(DESTDIR)$(BINDIR)/;\
+ done
+ # if test -d $(RIGFILTERS); then\
+ # for file in $(RFPROGS); do\