summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/phred/files')
-rw-r--r--sci-biology/phred/files/phred-071220-fix-build-system.patch82
-rw-r--r--sci-biology/phred/files/phred-071220-fix-qa.patch36
2 files changed, 0 insertions, 118 deletions
diff --git a/sci-biology/phred/files/phred-071220-fix-build-system.patch b/sci-biology/phred/files/phred-071220-fix-build-system.patch
deleted file mode 100644
index 997f39941a07..000000000000
--- a/sci-biology/phred/files/phred-071220-fix-build-system.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-* Fix build system to honour CC, CFLAGS, CPPFLAGS and LDFLAGS
-* Specify a default target, in order to keep the ebuild slim
-
---- a/Makefile
-+++ b/Makefile
-@@ -12,9 +12,9 @@
-
- # UNIX specific definitions (default)
- #
--CC= cc
--CFLAGS= -O -DANSI_C $(LXFLAGS)
--CLIB= -lm
-+CC ?= cc
-+CPPFLAGS += -DANSI_C $(LXFLAGS)
-+LIBS += -lm
-
- # Windows 'nmake' specific definitions
- #
-@@ -133,9 +133,6 @@
- $(objdir)writeSDF.o \
- $(objdir)writeSeq.o
-
--SRCS = $(OBJS:.o=.c)
--WOBJ = $(OBJS:.o=.obj)
--
- INCS = \
- $(incdir)chromatData.h \
- $(incdir)freeChromatData.h \
-@@ -179,48 +176,18 @@
- # UNIX make specific phred target
- # note: a horizontal tab character must precede `$(CC)'
- #
--phred: $(OBJS)
-- $(CC) $(CFLAGS) -o phred $(OBJS) $(CLIB)
-
-
--# Windows nmake specific phred target
--#
--forwindows: $(WOBJ)
-- $(CC) $(CFLAGS) /Fephred $(WOBJ)
--# $(CC) $(CFLAGS) /Fedaev daev.c
-+.PHONY: all
-+all: phred daev
-
-
--# test CC: refuse to compile if
--#
--# o SunOS
--#
--# AND
--#
--# o using /usr/ucb/cc compiler
--#
--# NOTE: this compiler causes problems: see PHRED.DOC
--#
--test_cc:
-- @if [ `uname` = SunOS ] ; \
-- then \
-- if [ `which $(CC)` = "/usr/ucb/cc" ] ; \
-- then \
-- echo ""; \
-- echo "============================================================"; \
-- echo "| |"; \
-- echo "| This SUN C compiler produces a bad phred executable. |"; \
-- echo "| |"; \
-- echo "| Please see the PHRED.DOC file for more information. |"; \
-- echo "| |"; \
-- echo "============================================================"; \
-- echo ""; \
-- exit 1; \
-- fi \
-- fi
-+phred: $(OBJS)
-+ $(CC) $(LDFLAGS) $(CFLAGS) -o phred $^ $(LIBS)
-
-
- daev: daev.o
-- $(CC) $(CFLAGS) -o daev daev.o -lm
-+ $(CC) $(LDFLAGS) $(CFLAGS) -o daev $^ $(LIBS)
-
-
- clean:
diff --git a/sci-biology/phred/files/phred-071220-fix-qa.patch b/sci-biology/phred/files/phred-071220-fix-qa.patch
deleted file mode 100644
index ab4d2ea023f6..000000000000
--- a/sci-biology/phred/files/phred-071220-fix-qa.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Fix implicit declarations:
-* daev.c: In function ‘processParameters’:
-* daev.c:849:14: warning: implicit declaration of function ‘isdigit’ [-Wimplicit-function-declaration]
-* if( !isdigit( argv[iarg][0] ) )
-
---- a/autoPhred.c
-+++ b/autoPhred.c
-@@ -57,6 +57,7 @@
- static int xstrcmp();
- #endif
-
-+int freeMBRData( MBRData *mbrData );
- #ifdef ANSI_C
- int autoPhred( Option *option )
- #else
---- a/daev.c
-+++ b/daev.c
-@@ -58,6 +58,7 @@
- #include <sys/stat.h>
- #include <time.h>
- #include <math.h>
-+#include <ctype.h>
-
- #ifndef _WIN32
- #include <dirent.h>
---- a/mergedBaseRead.c
-+++ b/mergedBaseRead.c
-@@ -63,7 +63,7 @@
- Peak *peak;
- Observed_peak *obs_peak;
-
-- static initFlag = 0;
-+ static int initFlag = 0;
- static char mchar[256][256];
-
- if( initFlag == 0 )