summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/abyss/Manifest1
-rw-r--r--sci-biology/abyss/abyss-2.0.3.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sci-biology/abyss/Manifest b/sci-biology/abyss/Manifest
index 20d851c721df..b18ccd652382 100644
--- a/sci-biology/abyss/Manifest
+++ b/sci-biology/abyss/Manifest
@@ -1 +1,2 @@
DIST abyss-2.0.2.tar.gz 1036135 BLAKE2B 6781a63203b5e6a1de70837a6dad7c79643d049b4c1e4b827471f2414cc821f82d98f9856518e3c24486e068c584520d0a1852d4e03d26247b896c776baaee41 SHA512 b19325b9d51e80378fc9818942c4005c94f470f0ad8ff6c1b8b593ad0216d35f9a99c0aa7c627082372690a6a7094ced8ca8efeb0bff6014ca46a67d7eb16a30
+DIST abyss-2.0.3.tar.gz 1049144 BLAKE2B 1a320cac735747225723f0d636af435ffcac9efb3273323150f258c0f4c27ed81bb104cb06a726aa664118cc9d2224b745d9deebfcac055face01dae3fc9de15 SHA512 15bc833e89839be89dfa35a23ae22ad0f9a19e8efd36211010c9f59e974de7c569576db36e26d6ab302543ff427604b5efb1b7badf62489a5e82a193ef155570
diff --git a/sci-biology/abyss/abyss-2.0.3.ebuild b/sci-biology/abyss/abyss-2.0.3.ebuild
new file mode 100644
index 000000000000..ccce937c77ce
--- /dev/null
+++ b/sci-biology/abyss/abyss-2.0.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Assembly By Short Sequences - a de novo, parallel, paired-end sequence assembler"
+HOMEPAGE="http://www.bcgsc.ca/platform/bioinfo/software/abyss/"
+SRC_URI="https://github.com/bcgsc/abyss/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="abyss"
+SLOT="0"
+IUSE="+mpi openmp misc-haskell"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-cpp/sparsehash
+ dev-libs/boost:=
+ misc-haskell? (
+ dev-libs/gmp:0=
+ virtual/libffi:0=
+ )
+ mpi? ( sys-cluster/openmpi )"
+DEPEND="${RDEPEND}
+ misc-haskell? (
+ dev-lang/ghc
+ )"
+
+# todo: --enable-maxk=N configure option
+# todo: fix automagic mpi toggling
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/-Werror//" configure.ac || die #365195
+ sed -i -e "/dist_pkgdoc_DATA/d" Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ # disable building haskell tool Misc/samtobreak
+ # unless request by user: bug #534412
+ use misc-haskell || export ac_cv_prog_ac_ct_GHC=
+
+ econf $(use_enable openmp)
+}