summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/rescan-scsi-bus')
-rw-r--r--sys-apps/rescan-scsi-bus/Manifest3
-rw-r--r--sys-apps/rescan-scsi-bus/files/rescan-scsi-bus-1.25-support-sysfs-only-systems.patch14
-rw-r--r--sys-apps/rescan-scsi-bus/metadata.xml8
-rw-r--r--sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.29.ebuild41
-rw-r--r--sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.56.ebuild41
-rw-r--r--sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.57-r1.ebuild36
-rw-r--r--sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.57.ebuild35
7 files changed, 178 insertions, 0 deletions
diff --git a/sys-apps/rescan-scsi-bus/Manifest b/sys-apps/rescan-scsi-bus/Manifest
new file mode 100644
index 000000000000..5b28516757c6
--- /dev/null
+++ b/sys-apps/rescan-scsi-bus/Manifest
@@ -0,0 +1,3 @@
+DIST rescan-scsi-bus.sh-1.29 15654 SHA256 355f30d15b44159389baabac496882243974c9df4054d8a69ca2141822af8466 SHA512 dc6bfc5b8c4948c193bcf2522e6f4dedaacf9a9283eaedc9c3bcef0cf3db57a3ed8f3a95b8501853a75e1c83ad28850b291a76217b4c57690e663f3dc63587d7 WHIRLPOOL 1704b669a762b7f0a83afb394ad786dd9ae174a39a2e04325b83dbd2c4dfa58d3af9f94aaf1ce3c205ea44ac5ba8b8b8050916ebe6f7bce3b5d18a8ee539b288
+DIST rescan-scsi-bus.sh-1.56 22469 SHA256 d84a89a1f9162ca7711c5b1f18f4c036a41c231d15b4feeba0b50f815dcaf43d SHA512 bdd27471568b1ce8b4d9ccc6783f294d141d56c5d5fa5ad46a7ffe983efd46877e25ff67b7869edb4e22ad182d47140c2167a58b80a141f4b3dde9c7e10ae57b WHIRLPOOL 5ef7d71a653742c3ded4a4e3f570886e9161f7eab59692e57f46ecf0531de3c891d872328d0d5dc73fe67a90945e28bd9d08bbb15aad43f5e00a62084f87468d
+DIST rescan-scsi-bus.sh-1.57 22575 SHA256 91c3ffbbf27d799cb1adacc026a5a8f31d5d107b0adedc41e4b7d6af9fb3e70f SHA512 93a061af852e5f9dd3d64ad62692809a11d8ffaac68f5ce08ba1a4fd9201fc66a0a5482d3e6da6e5c36fb00805fa4f7483fc2c85c5aaf6bfc190690ccf7bc733 WHIRLPOOL 2568f857cd315d5b0c9259c6d0afa2ac5871c959ff77c1b408d734ba46860e0ec3bcadd8eed76d02e95ab87fd768fcfa707cf559c291ab45b1f65cff526fd421
diff --git a/sys-apps/rescan-scsi-bus/files/rescan-scsi-bus-1.25-support-sysfs-only-systems.patch b/sys-apps/rescan-scsi-bus/files/rescan-scsi-bus-1.25-support-sysfs-only-systems.patch
new file mode 100644
index 000000000000..7d890d0d5f66
--- /dev/null
+++ b/sys-apps/rescan-scsi-bus/files/rescan-scsi-bus-1.25-support-sysfs-only-systems.patch
@@ -0,0 +1,14 @@
+--- rescan-scsi-bus.sh.orig 2008-01-15 01:01:21.316547000 -0800
++++ rescan-scsi-bus.sh 2008-01-15 01:02:02.704184735 -0800
+@@ -444,7 +444,10 @@
+ echo $result
+ }
+
+-if test ! -d /proc/scsi/; then
++# /proc/scsi may not exist in new 2.6 kernels without CONFIG_SCSI_PROC_FS
++if test -d /proc/scsi/ || test -d /sys/bus/scsi/; then
++ :
++else
+ echo "Error: SCSI subsystem not active"
+ exit 1
+ fi
diff --git a/sys-apps/rescan-scsi-bus/metadata.xml b/sys-apps/rescan-scsi-bus/metadata.xml
new file mode 100644
index 000000000000..035bc6b0e2cd
--- /dev/null
+++ b/sys-apps/rescan-scsi-bus/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.29.ebuild b/sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.29.ebuild
new file mode 100644
index 000000000000..c90b62a6f937
--- /dev/null
+++ b/sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.29.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Script to rescan the SCSI bus without rebooting"
+HOMEPAGE="http://www.garloff.de/kurt/linux/"
+SCRIPT_NAME="${PN}.sh"
+SRC_NAME="${SCRIPT_NAME}-${PV}"
+SRC_URI="http://www.garloff.de/kurt/linux/${SRC_NAME}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=sys-apps/sg3_utils-1.24
+ virtual/modutils
+ app-shells/bash"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ einfo "Unpacking into ${WORKDIR}/"
+ cp -f "${DISTDIR}"/${SRC_NAME} "${WORKDIR}"/${SCRIPT_NAME}
+ #epatch "${FILESDIR}"/${P}-support-sysfs-only-systems.patch
+}
+
+src_compile() {
+ einfo "Nothing to compile"
+}
+
+src_install() {
+ into /usr
+ dosbin ${SCRIPT_NAME}
+ # Some scripts look for this without the trailing .sh
+ # Some look for it with the trailing .sh, so have a symlink
+ dosym ${SCRIPT_NAME} /usr/sbin/${PN}
+}
diff --git a/sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.56.ebuild b/sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.56.ebuild
new file mode 100644
index 000000000000..53a3150b0cc8
--- /dev/null
+++ b/sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.56.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Script to rescan the SCSI bus without rebooting"
+HOMEPAGE="http://www.garloff.de/kurt/linux/"
+SCRIPT_NAME="${PN}.sh"
+SRC_NAME="${SCRIPT_NAME}-${PV}"
+SRC_URI="http://www.garloff.de/kurt/linux/${SRC_NAME}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=sys-apps/sg3_utils-1.24
+ virtual/modutils
+ app-shells/bash"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ einfo "Unpacking into ${WORKDIR}/"
+ cp -f "${DISTDIR}"/${SRC_NAME} "${WORKDIR}"/${SCRIPT_NAME}
+ #epatch "${FILESDIR}"/${P}-support-sysfs-only-systems.patch
+}
+
+src_compile() {
+ einfo "Nothing to compile"
+}
+
+src_install() {
+ into /usr
+ dosbin ${SCRIPT_NAME}
+ # Some scripts look for this without the trailing .sh
+ # Some look for it with the trailing .sh, so have a symlink
+ dosym ${SCRIPT_NAME} /usr/sbin/${PN}
+}
diff --git a/sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.57-r1.ebuild b/sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.57-r1.ebuild
new file mode 100644
index 000000000000..b75e81bbf260
--- /dev/null
+++ b/sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.57-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Script to rescan the SCSI bus without rebooting"
+HOMEPAGE="http://www.garloff.de/kurt/linux/"
+SCRIPT_NAME="${PN}.sh"
+SRC_NAME="${SCRIPT_NAME}-${PV}"
+SRC_URI="http://www.garloff.de/kurt/linux/${SRC_NAME}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86" # alpha hppa ppc64 sparc
+
+RDEPEND=">=sys-apps/sg3_utils-1.24
+ app-admin/killproc
+ virtual/modutils
+ app-shells/bash"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp -f "${DISTDIR}"/${SRC_NAME} "${WORKDIR}"/${SCRIPT_NAME}
+}
+
+src_install() {
+ into /usr
+ dosbin ${SCRIPT_NAME}
+ # Some scripts look for this without the trailing .sh
+ # Some look for it with the trailing .sh, so have a symlink
+ dosym ${SCRIPT_NAME} /usr/sbin/${PN}
+}
diff --git a/sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.57.ebuild b/sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.57.ebuild
new file mode 100644
index 000000000000..a7609810e962
--- /dev/null
+++ b/sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.57.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Script to rescan the SCSI bus without rebooting"
+HOMEPAGE="http://www.garloff.de/kurt/linux/"
+SCRIPT_NAME="${PN}.sh"
+SRC_NAME="${SCRIPT_NAME}-${PV}"
+SRC_URI="http://www.garloff.de/kurt/linux/${SRC_NAME}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+RDEPEND=">=sys-apps/sg3_utils-1.24
+ virtual/modutils
+ app-shells/bash"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp -f "${DISTDIR}"/${SRC_NAME} "${WORKDIR}"/${SCRIPT_NAME}
+}
+
+src_install() {
+ into /usr
+ dosbin ${SCRIPT_NAME}
+ # Some scripts look for this without the trailing .sh
+ # Some look for it with the trailing .sh, so have a symlink
+ dosym ${SCRIPT_NAME} /usr/sbin/${PN}
+}