summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/superiotool/superiotool-99999999.ebuild')
-rw-r--r--sys-apps/superiotool/superiotool-99999999.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/sys-apps/superiotool/superiotool-99999999.ebuild b/sys-apps/superiotool/superiotool-99999999.ebuild
deleted file mode 100644
index bdd2a856660e..000000000000
--- a/sys-apps/superiotool/superiotool-99999999.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-if [[ ${PV} == *99999999 ]] ; then
- ESVN_REPO_URI="svn://coreboot.org/coreboot/trunk/util/${PN}"
- inherit subversion
-else
- SRC_URI="mirror://gentoo/${P}.tar.xz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="util to detect Super I/O chips and functionality"
-HOMEPAGE="https://www.coreboot.org/Superiotool"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="pci"
-
-RDEPEND="pci? ( sys-apps/pciutils )"
-DEPEND="${RDEPEND}
- app-arch/xz-utils"
-
-src_prepare() {
- default
-
- sed -i \
- -e 's:-Werror ::' \
- -e 's:-O2 ::' \
- -e 's:\s\+\?-lz\s\+\?::' \
- -e "/^CONFIG_PCI =/s:=.*:=$(usex pci yes no):" \
- -e '/PREFIX/s:=.*:= /usr:' \
- Makefile || die
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- SVNDEF="-D'SUPERIOTOOL_VERSION=\"${ESVN_WC_REVISION}\"'"
-}