summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/superiotool')
-rw-r--r--sys-apps/superiotool/Manifest1
-rwxr-xr-xsys-apps/superiotool/files/make-tarball.sh34
-rw-r--r--sys-apps/superiotool/metadata.xml8
-rw-r--r--sys-apps/superiotool/superiotool-6637.ebuild43
-rw-r--r--sys-apps/superiotool/superiotool-99999999.ebuild43
5 files changed, 0 insertions, 129 deletions
diff --git a/sys-apps/superiotool/Manifest b/sys-apps/superiotool/Manifest
deleted file mode 100644
index 81eb3d416236..000000000000
--- a/sys-apps/superiotool/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST superiotool-6637.tar.xz 27364 BLAKE2B be0fd054f1385c20ca1d3da04052f7155da77211c1a4253c58c0ee272944e4134b1df6213934ea0ab6c297da9ab09ceab1cc00dcd775633d7ba50f46cba8ffb8 SHA512 dafb732b33205d1bdd368c1f752c7ba78cfb9f6174fc72075b9e8dcae962ab9ef10eb0860052a5925167b91e5b056f6b8a4a316799661d3950a630020f4330fd
diff --git a/sys-apps/superiotool/files/make-tarball.sh b/sys-apps/superiotool/files/make-tarball.sh
deleted file mode 100755
index fa6254898d1f..000000000000
--- a/sys-apps/superiotool/files/make-tarball.sh
+++ /dev/null
@@ -1,34 +0,0 @@
-#!/bin/bash
-
-. /lib/gentoo/functions.sh
-
-svnrev() { svn info "$1" | awk '$1 == "Revision:" { print $NF }'; }
-
-PN=superiotool
-SVN_ROOT=${2:-/usr/local/src}
-srcdir=${SVN_ROOT}/${PN}
-PV=${1:-$(svnrev "${srcdir}")}
-
-P=${PN}-${PV}
-T=/tmp
-
-if [[ -d ${srcdir} ]] ; then
- cd "${T}" || die
-
- rm -rf ${P}
-
- ebegin "Exporting ${srcdir} ${PV} to ${P}"
- svn export -q -r ${PV} ${srcdir} ${P}
- eend $? || die
-
- ebegin "Creating ${P}.tar.xz"
- tar cf - ${P} | xz > ${P}.tar.xz
- eend $?
-
- einfo "Tarball now ready at: ${T}/${P}.tar.xz"
-else
- einfo "You need to run:"
- einfo " cd ${base}"
- einfo " svn co svn://coreboot.org/coreboot/trunk/util/superiotool"
- die "need svn checkout dir"
-fi
diff --git a/sys-apps/superiotool/metadata.xml b/sys-apps/superiotool/metadata.xml
deleted file mode 100644
index 3d1af92d107c..000000000000
--- a/sys-apps/superiotool/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <use>
- <flag name="pci">Support for PCI-attached "Super I/Os" (e.g. in VIA VT82686A/B).</flag>
- </use>
-</pkgmetadata>
diff --git a/sys-apps/superiotool/superiotool-6637.ebuild b/sys-apps/superiotool/superiotool-6637.ebuild
deleted file mode 100644
index bdd2a856660e..000000000000
--- a/sys-apps/superiotool/superiotool-6637.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-if [[ ${PV} == *99999999 ]] ; then
- ESVN_REPO_URI="svn://coreboot.org/coreboot/trunk/util/${PN}"
- inherit subversion
-else
- SRC_URI="mirror://gentoo/${P}.tar.xz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="util to detect Super I/O chips and functionality"
-HOMEPAGE="https://www.coreboot.org/Superiotool"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="pci"
-
-RDEPEND="pci? ( sys-apps/pciutils )"
-DEPEND="${RDEPEND}
- app-arch/xz-utils"
-
-src_prepare() {
- default
-
- sed -i \
- -e 's:-Werror ::' \
- -e 's:-O2 ::' \
- -e 's:\s\+\?-lz\s\+\?::' \
- -e "/^CONFIG_PCI =/s:=.*:=$(usex pci yes no):" \
- -e '/PREFIX/s:=.*:= /usr:' \
- Makefile || die
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- SVNDEF="-D'SUPERIOTOOL_VERSION=\"${ESVN_WC_REVISION}\"'"
-}
diff --git a/sys-apps/superiotool/superiotool-99999999.ebuild b/sys-apps/superiotool/superiotool-99999999.ebuild
deleted file mode 100644
index bdd2a856660e..000000000000
--- a/sys-apps/superiotool/superiotool-99999999.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-if [[ ${PV} == *99999999 ]] ; then
- ESVN_REPO_URI="svn://coreboot.org/coreboot/trunk/util/${PN}"
- inherit subversion
-else
- SRC_URI="mirror://gentoo/${P}.tar.xz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="util to detect Super I/O chips and functionality"
-HOMEPAGE="https://www.coreboot.org/Superiotool"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="pci"
-
-RDEPEND="pci? ( sys-apps/pciutils )"
-DEPEND="${RDEPEND}
- app-arch/xz-utils"
-
-src_prepare() {
- default
-
- sed -i \
- -e 's:-Werror ::' \
- -e 's:-O2 ::' \
- -e 's:\s\+\?-lz\s\+\?::' \
- -e "/^CONFIG_PCI =/s:=.*:=$(usex pci yes no):" \
- -e '/PREFIX/s:=.*:= /usr:' \
- Makefile || die
-}
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- SVNDEF="-D'SUPERIOTOOL_VERSION=\"${ESVN_WC_REVISION}\"'"
-}