summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
index b5eea1980e7d..fb90bbaab7cf 100644
--- a/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
@@ -62,9 +62,9 @@ src_configure() {
if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++
+ strip-unsupported-flags
# ensure we can use clang before installing compiler-rt
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
- strip-unsupported-flags
elif ! test_compiler; then
if test_compiler "${nolib_flags[@]}"; then
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"