summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-29 09:47:41 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-29 09:47:41 +0100
commit8e283ddd7e7cfd33203278872556a5b7db34eaa1 (patch)
tree6b80232419e4f093c535c06d5551ed57b3035872 /sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
parentdev-python/lxml: Bump to 4.4.3 (diff)
downloadgentoo-8e283ddd7e7cfd33203278872556a5b7db34eaa1.tar.gz
gentoo-8e283ddd7e7cfd33203278872556a5b7db34eaa1.tar.bz2
gentoo-8e283ddd7e7cfd33203278872556a5b7db34eaa1.zip
sys-libs/compiler-rt: Fix stripping -nodefaultlibs
Closes: https://bugs.gentoo.org/706266 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
index b5eea1980e7d..fb90bbaab7cf 100644
--- a/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
@@ -62,9 +62,9 @@ src_configure() {
if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++
+ strip-unsupported-flags
# ensure we can use clang before installing compiler-rt
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
- strip-unsupported-flags
elif ! test_compiler; then
if test_compiler "${nolib_flags[@]}"; then
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"