summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/liboglappth/liboglappth-0.98.ebuild')
-rw-r--r--x11-libs/liboglappth/liboglappth-0.98.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-libs/liboglappth/liboglappth-0.98.ebuild b/x11-libs/liboglappth/liboglappth-0.98.ebuild
new file mode 100644
index 000000000000..ca703827b2f3
--- /dev/null
+++ b/x11-libs/liboglappth/liboglappth-0.98.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="A library for creating portable OpenGL applications with easy-to-code scene setup and selection"
+HOMEPAGE="http://www.bioinformatics.org/ghemical/"
+SRC_URI="http://www.bioinformatics.org/ghemical/download/current/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+RDEPEND="virtual/opengl
+ media-libs/freeglut"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/gcc-4.3.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}