summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/liboglappth')
-rw-r--r--x11-libs/liboglappth/Manifest2
-rw-r--r--x11-libs/liboglappth/files/gcc-4.3.patch10
-rw-r--r--x11-libs/liboglappth/liboglappth-0.98.ebuild27
-rw-r--r--x11-libs/liboglappth/liboglappth-1.0.0.ebuild27
-rw-r--r--x11-libs/liboglappth/metadata.xml12
5 files changed, 78 insertions, 0 deletions
diff --git a/x11-libs/liboglappth/Manifest b/x11-libs/liboglappth/Manifest
new file mode 100644
index 000000000000..905550beac0e
--- /dev/null
+++ b/x11-libs/liboglappth/Manifest
@@ -0,0 +1,2 @@
+DIST liboglappth-0.98.tar.gz 326755 SHA256 1ec5964bb281215d5c6e58dee7e5a1a8bcaef2e07df4ac1336ec404b701a11c1
+DIST liboglappth-1.0.0.tar.gz 325178 SHA256 b461a31065d6912d190f78ad0041218009f44a5acdb5757545bd4a8bd6b509aa SHA512 b0d883379650f1062d503d2adaab48202614b3ab68eba2e0ab01513b51cdd88f75fa02af5dcb00077fb057cdf09987dfe123ea9e0541e2e56893e11e53ac8ef1 WHIRLPOOL e01b177d75584cc6fda99396d0353fa5444f426e1616492defe19f32eb2d53b62b5353967f2c76024daca16e3f7c02bec5e70507cd04a1a3197dfee57ce5b2ac
diff --git a/x11-libs/liboglappth/files/gcc-4.3.patch b/x11-libs/liboglappth/files/gcc-4.3.patch
new file mode 100644
index 000000000000..7a70ab2a2659
--- /dev/null
+++ b/x11-libs/liboglappth/files/gcc-4.3.patch
@@ -0,0 +1,10 @@
+--- liboglappth-0.96.orig/src/base_wcl.cpp 2008-07-07 23:49:10.000000000 -0700
++++ liboglappth-0.96/src/base_wcl.cpp 2008-07-07 23:49:26.000000000 -0700
+@@ -11,6 +11,7 @@
+
+ #include "base_app.h"
+ #include <stdlib.h> // the definition for NULL...
++#include <cstring>
+
+ #include <GL/glut.h>
+
diff --git a/x11-libs/liboglappth/liboglappth-0.98.ebuild b/x11-libs/liboglappth/liboglappth-0.98.ebuild
new file mode 100644
index 000000000000..ca703827b2f3
--- /dev/null
+++ b/x11-libs/liboglappth/liboglappth-0.98.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="A library for creating portable OpenGL applications with easy-to-code scene setup and selection"
+HOMEPAGE="http://www.bioinformatics.org/ghemical/"
+SRC_URI="http://www.bioinformatics.org/ghemical/download/current/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+RDEPEND="virtual/opengl
+ media-libs/freeglut"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/gcc-4.3.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/x11-libs/liboglappth/liboglappth-1.0.0.ebuild b/x11-libs/liboglappth/liboglappth-1.0.0.ebuild
new file mode 100644
index 000000000000..141cab92ab19
--- /dev/null
+++ b/x11-libs/liboglappth/liboglappth-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="A library for creating portable OpenGL applications with easy-to-code scene setup and selection"
+HOMEPAGE="http://www.bioinformatics.org/ghemical/"
+SRC_URI="http://www.bioinformatics.org/ghemical/download/current/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RDEPEND="virtual/opengl
+ media-libs/freeglut"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/gcc-4.3.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/x11-libs/liboglappth/metadata.xml b/x11-libs/liboglappth/metadata.xml
new file mode 100644
index 000000000000..81439daa1259
--- /dev/null
+++ b/x11-libs/liboglappth/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+<longdescription>
+Ghemical supports both quantum-mechanics (semi-empirical and ab initio) models
+and molecular mechanics models (there is an experimental Tripos 5.2-like force
+field for organic molecules). Also a tool for reduced protein models is
+included. Geometry optimization, molecular dynamics and a large set of
+visualization tools are currently available.
+</longdescription>
+</pkgmetadata>