summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libtinynotify/libtinynotify-9999.ebuild')
-rw-r--r--x11-libs/libtinynotify/libtinynotify-9999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-libs/libtinynotify/libtinynotify-9999.ebuild b/x11-libs/libtinynotify/libtinynotify-9999.ebuild
new file mode 100644
index 000000000000..688da83d4204
--- /dev/null
+++ b/x11-libs/libtinynotify/libtinynotify-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}.git"
+
+inherit git-r3
+#endif
+
+inherit autotools-utils
+
+DESCRIPTION="A lightweight implementation of Desktop Notification Spec"
+HOMEPAGE="https://bitbucket.org/mgorny/libtinynotify/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc static-libs"
+
+RDEPEND="sys-apps/dbus:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.18 )"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+DEPEND="${DEPEND}
+ >=dev-util/gtk-doc-1.18"
+#endif
+
+src_configure() {
+ myeconfargs=(
+ $(use_enable debug)
+ $(use_enable doc gtk-doc)
+ )
+
+ autotools-utils_src_configure
+}