summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libtinynotify')
-rw-r--r--x11-libs/libtinynotify/Manifest1
-rw-r--r--x11-libs/libtinynotify/libtinynotify-0.2.1.ebuild32
-rw-r--r--x11-libs/libtinynotify/libtinynotify-9999.ebuild44
-rw-r--r--x11-libs/libtinynotify/metadata.xml16
4 files changed, 93 insertions, 0 deletions
diff --git a/x11-libs/libtinynotify/Manifest b/x11-libs/libtinynotify/Manifest
new file mode 100644
index 000000000000..8f16ca2b5914
--- /dev/null
+++ b/x11-libs/libtinynotify/Manifest
@@ -0,0 +1 @@
+DIST libtinynotify-0.2.1.tar.bz2 286167 SHA256 2fee7d2f1bb17f1a5c499d32490ded06c1fd9e4300d0edf1b65615c5914dd07b SHA512 4d1d4eb56a654aef523aa5a81cafd51b64f7bf44130f3043d5d6b6ea88fbc7681d96cbde3c16cd00eb141145cb551018129f4bab03f542bf88425beda41cdca3 WHIRLPOOL 6a507e95b8dd9f7884f55f000ef2d76102f5b28b99bfc15f15466487229204b685099a7e6edeb3be1c07203d9f2dc3a3a666e92a22d16d1dc709727aa29d102b
diff --git a/x11-libs/libtinynotify/libtinynotify-0.2.1.ebuild b/x11-libs/libtinynotify/libtinynotify-0.2.1.ebuild
new file mode 100644
index 000000000000..411ac059ba7a
--- /dev/null
+++ b/x11-libs/libtinynotify/libtinynotify-0.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="A lightweight implementation of Desktop Notification Spec"
+HOMEPAGE="https://github.com/mgorny/libtinynotify/"
+SRC_URI="mirror://github/mgorny/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc static-libs"
+
+RDEPEND="sys-apps/dbus"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.18 )"
+
+DOCS=( README )
+
+src_configure() {
+ myeconfargs=(
+ $(use_enable debug)
+ $(use_enable doc gtk-doc)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/x11-libs/libtinynotify/libtinynotify-9999.ebuild b/x11-libs/libtinynotify/libtinynotify-9999.ebuild
new file mode 100644
index 000000000000..688da83d4204
--- /dev/null
+++ b/x11-libs/libtinynotify/libtinynotify-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}.git"
+
+inherit git-r3
+#endif
+
+inherit autotools-utils
+
+DESCRIPTION="A lightweight implementation of Desktop Notification Spec"
+HOMEPAGE="https://bitbucket.org/mgorny/libtinynotify/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc static-libs"
+
+RDEPEND="sys-apps/dbus:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.18 )"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+DEPEND="${DEPEND}
+ >=dev-util/gtk-doc-1.18"
+#endif
+
+src_configure() {
+ myeconfargs=(
+ $(use_enable debug)
+ $(use_enable doc gtk-doc)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/x11-libs/libtinynotify/metadata.xml b/x11-libs/libtinynotify/metadata.xml
new file mode 100644
index 000000000000..32808ea93fc4
--- /dev/null
+++ b/x11-libs/libtinynotify/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>https://bitbucket.org/mgorny/libtinynotify/issues/</bugs-to>
+ <remote-id type="bitbucket">mgorny/libtinynotify</remote-id>
+ </upstream>
+</pkgmetadata>