summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/xvba-video/files')
-rw-r--r--x11-libs/xvba-video/files/xvba-video-0.8.0-VAEncH264VUIBufferType.patch12
-rw-r--r--x11-libs/xvba-video/files/xvba-video-0.8.0-assert-hw_image_hooks_glx.patch12
-rw-r--r--x11-libs/xvba-video/files/xvba-video-fix-mesa-gl.h.patch17
-rw-r--r--x11-libs/xvba-video/files/xvba-video-fix-out-of-source-builds.patch11
4 files changed, 52 insertions, 0 deletions
diff --git a/x11-libs/xvba-video/files/xvba-video-0.8.0-VAEncH264VUIBufferType.patch b/x11-libs/xvba-video/files/xvba-video-0.8.0-VAEncH264VUIBufferType.patch
new file mode 100644
index 000000000000..3542d4ee6d19
--- /dev/null
+++ b/x11-libs/xvba-video/files/xvba-video-0.8.0-VAEncH264VUIBufferType.patch
@@ -0,0 +1,12 @@
+diff -ur a/src/xvba_dump.c b/src/xvba_dump.c
+--- a/src/xvba_dump.c 2012-11-23 14:29:10.000000000 +0100
++++ b/src/xvba_dump.c 2014-03-03 18:53:08.772012251 +0100
+@@ -150,8 +150,6 @@
+ _(VAEncSequenceParameterBufferType);
+ _(VAEncPictureParameterBufferType);
+ _(VAEncSliceParameterBufferType);
+- _(VAEncH264VUIBufferType);
+- _(VAEncH264SEIBufferType);
+ #endif
+ #undef _
+ }
diff --git a/x11-libs/xvba-video/files/xvba-video-0.8.0-assert-hw_image_hooks_glx.patch b/x11-libs/xvba-video/files/xvba-video-0.8.0-assert-hw_image_hooks_glx.patch
new file mode 100644
index 000000000000..7cb249a16f48
--- /dev/null
+++ b/x11-libs/xvba-video/files/xvba-video-0.8.0-assert-hw_image_hooks_glx.patch
@@ -0,0 +1,12 @@
+diff -ur xvba-video-0.8.0/src/xvba_image.c xvba-video-0.8.0-patched/src/xvba_image.c
+--- xvba-video-0.8.0/src/xvba_image.c 2011-06-14 13:07:13.000000000 +0200
++++ xvba-video-0.8.0-patched/src/xvba_image.c 2012-07-22 14:55:14.186667413 +0200
+@@ -423,7 +423,7 @@
+ }
+
+ #if USE_GLX
+-const HWImageHooks hw_image_hooks_glx attribute_hidden;
++extern const HWImageHooks hw_image_hooks_glx attribute_hidden;
+ #endif
+
+ // Commit image to the HW
diff --git a/x11-libs/xvba-video/files/xvba-video-fix-mesa-gl.h.patch b/x11-libs/xvba-video/files/xvba-video-fix-mesa-gl.h.patch
new file mode 100644
index 000000000000..578d3321d92d
--- /dev/null
+++ b/x11-libs/xvba-video/files/xvba-video-fix-mesa-gl.h.patch
@@ -0,0 +1,17 @@
+diff -urN xvba-driver-0.8.0.old/src/utils_glx.h xvba-driver-0.8.0/src/utils_glx.h
+--- xvba-driver-0.8.0.old/src/utils_glx.h 2013-02-04 20:04:00.476332874 +0100
++++ xvba-driver-0.8.0/src/utils_glx.h 2013-02-04 20:04:40.228329931 +0100
+@@ -25,6 +25,13 @@
+ #include <GL/glext.h>
+ #include <GL/glx.h>
+
++
++#if GL_GLEXT_VERSION >= 85
++/* XXX: PFNGLMULTITEXCOORD2FPROC got out of the GL_VERSION_1_3_DEPRECATED
++ block and is not defined if GL_VERSION_1_3 is defined in <GL/gl.h>
++ Redefine the type here as an interim solution */
++typedef void (*PFNGLMULTITEXCOORD2FPROC) (GLenum target, GLfloat s, GLfloat t);
++#endif
+ #ifndef GL_FRAMEBUFFER_BINDING
+ #define GL_FRAMEBUFFER_BINDING GL_FRAMEBUFFER_BINDING_EXT
+ #endif
diff --git a/x11-libs/xvba-video/files/xvba-video-fix-out-of-source-builds.patch b/x11-libs/xvba-video/files/xvba-video-fix-out-of-source-builds.patch
new file mode 100644
index 000000000000..23de8559a07a
--- /dev/null
+++ b/x11-libs/xvba-video/files/xvba-video-fix-out-of-source-builds.patch
@@ -0,0 +1,11 @@
+--- src/shaders/Makefile.am 2012-11-23 08:29:10.000000000 -0500
++++ src/shaders/Makefile.am.new 2014-01-30 18:38:27.954753460 -0500
+@@ -25,7 +25,7 @@
+ CLEANFILES += $(shaders_h)
+
+ %.h: %.pso pso2h.py
+- $(PYTHON) pso2h.py -n $*_fp -o $@ $<
++ $(PYTHON) $(top_srcdir)/src/shaders/pso2h.py -n $*_fp -o $@ $<
+ endif
+
+ # Only add those targets if the Cg compiler is available