summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/xvba-video/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/xvba-video/files')
-rw-r--r--x11-libs/xvba-video/files/xvba-video-0.8.0-VAEncH264VUIBufferType.patch12
-rw-r--r--x11-libs/xvba-video/files/xvba-video-0.8.0-assert-hw_image_hooks_glx.patch12
-rw-r--r--x11-libs/xvba-video/files/xvba-video-fix-mesa-gl.h.patch17
-rw-r--r--x11-libs/xvba-video/files/xvba-video-fix-out-of-source-builds.patch11
4 files changed, 52 insertions, 0 deletions
diff --git a/x11-libs/xvba-video/files/xvba-video-0.8.0-VAEncH264VUIBufferType.patch b/x11-libs/xvba-video/files/xvba-video-0.8.0-VAEncH264VUIBufferType.patch
new file mode 100644
index 000000000000..3542d4ee6d19
--- /dev/null
+++ b/x11-libs/xvba-video/files/xvba-video-0.8.0-VAEncH264VUIBufferType.patch
@@ -0,0 +1,12 @@
+diff -ur a/src/xvba_dump.c b/src/xvba_dump.c
+--- a/src/xvba_dump.c 2012-11-23 14:29:10.000000000 +0100
++++ b/src/xvba_dump.c 2014-03-03 18:53:08.772012251 +0100
+@@ -150,8 +150,6 @@
+ _(VAEncSequenceParameterBufferType);
+ _(VAEncPictureParameterBufferType);
+ _(VAEncSliceParameterBufferType);
+- _(VAEncH264VUIBufferType);
+- _(VAEncH264SEIBufferType);
+ #endif
+ #undef _
+ }
diff --git a/x11-libs/xvba-video/files/xvba-video-0.8.0-assert-hw_image_hooks_glx.patch b/x11-libs/xvba-video/files/xvba-video-0.8.0-assert-hw_image_hooks_glx.patch
new file mode 100644
index 000000000000..7cb249a16f48
--- /dev/null
+++ b/x11-libs/xvba-video/files/xvba-video-0.8.0-assert-hw_image_hooks_glx.patch
@@ -0,0 +1,12 @@
+diff -ur xvba-video-0.8.0/src/xvba_image.c xvba-video-0.8.0-patched/src/xvba_image.c
+--- xvba-video-0.8.0/src/xvba_image.c 2011-06-14 13:07:13.000000000 +0200
++++ xvba-video-0.8.0-patched/src/xvba_image.c 2012-07-22 14:55:14.186667413 +0200
+@@ -423,7 +423,7 @@
+ }
+
+ #if USE_GLX
+-const HWImageHooks hw_image_hooks_glx attribute_hidden;
++extern const HWImageHooks hw_image_hooks_glx attribute_hidden;
+ #endif
+
+ // Commit image to the HW
diff --git a/x11-libs/xvba-video/files/xvba-video-fix-mesa-gl.h.patch b/x11-libs/xvba-video/files/xvba-video-fix-mesa-gl.h.patch
new file mode 100644
index 000000000000..578d3321d92d
--- /dev/null
+++ b/x11-libs/xvba-video/files/xvba-video-fix-mesa-gl.h.patch
@@ -0,0 +1,17 @@
+diff -urN xvba-driver-0.8.0.old/src/utils_glx.h xvba-driver-0.8.0/src/utils_glx.h
+--- xvba-driver-0.8.0.old/src/utils_glx.h 2013-02-04 20:04:00.476332874 +0100
++++ xvba-driver-0.8.0/src/utils_glx.h 2013-02-04 20:04:40.228329931 +0100
+@@ -25,6 +25,13 @@
+ #include <GL/glext.h>
+ #include <GL/glx.h>
+
++
++#if GL_GLEXT_VERSION >= 85
++/* XXX: PFNGLMULTITEXCOORD2FPROC got out of the GL_VERSION_1_3_DEPRECATED
++ block and is not defined if GL_VERSION_1_3 is defined in <GL/gl.h>
++ Redefine the type here as an interim solution */
++typedef void (*PFNGLMULTITEXCOORD2FPROC) (GLenum target, GLfloat s, GLfloat t);
++#endif
+ #ifndef GL_FRAMEBUFFER_BINDING
+ #define GL_FRAMEBUFFER_BINDING GL_FRAMEBUFFER_BINDING_EXT
+ #endif
diff --git a/x11-libs/xvba-video/files/xvba-video-fix-out-of-source-builds.patch b/x11-libs/xvba-video/files/xvba-video-fix-out-of-source-builds.patch
new file mode 100644
index 000000000000..23de8559a07a
--- /dev/null
+++ b/x11-libs/xvba-video/files/xvba-video-fix-out-of-source-builds.patch
@@ -0,0 +1,11 @@
+--- src/shaders/Makefile.am 2012-11-23 08:29:10.000000000 -0500
++++ src/shaders/Makefile.am.new 2014-01-30 18:38:27.954753460 -0500
+@@ -25,7 +25,7 @@
+ CLEANFILES += $(shaders_h)
+
+ %.h: %.pso pso2h.py
+- $(PYTHON) pso2h.py -n $*_fp -o $@ $<
++ $(PYTHON) $(top_srcdir)/src/shaders/pso2h.py -n $*_fp -o $@ $<
+ endif
+
+ # Only add those targets if the Cg compiler is available