summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-02-16 15:08:09 -0500
committerBrian Evans <grknight@gentoo.org>2018-02-16 17:00:00 -0500
commita46e68ce01a88185686db7e1bbd0b95f43b8ee0c (patch)
treef625043501c778ffbe9d99b214fc8b48e9139735 /dev-php/PEAR-File_Fortune/PEAR-File_Fortune-1.0.0-r1.ebuild
parentdev-php/PEAR-File: Revbump adding tests, EAPI and eclass changes (diff)
downloadgentoo-a46e68ce01a88185686db7e1bbd0b95f43b8ee0c.tar.gz
gentoo-a46e68ce01a88185686db7e1bbd0b95f43b8ee0c.tar.bz2
gentoo-a46e68ce01a88185686db7e1bbd0b95f43b8ee0c.zip
dev-php/PEAR-File_Fortune: Revbump to add tests and for EAPI/eclass
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-php/PEAR-File_Fortune/PEAR-File_Fortune-1.0.0-r1.ebuild')
-rw-r--r--dev-php/PEAR-File_Fortune/PEAR-File_Fortune-1.0.0-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-php/PEAR-File_Fortune/PEAR-File_Fortune-1.0.0-r1.ebuild b/dev-php/PEAR-File_Fortune/PEAR-File_Fortune-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..ec5a405cb607
--- /dev/null
+++ b/dev-php/PEAR-File_Fortune/PEAR-File_Fortune-1.0.0-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="Interface for reading from and writing to fortune files"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-lang/php-5.1.4:*"
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+
+src_test(){
+ phpunit tests || die
+}