summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-10-28 16:52:16 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-10-30 00:15:09 +0100
commit66316ff45e6df5c0399fafeb7685188fced32efb (patch)
treea835175bd9213ee4d00528fe178ff898c5cedc9c /dev-python/rtimulib
parentdev-python/python-sense-hat: drop old version. (diff)
downloadgentoo-66316ff45e6df5c0399fafeb7685188fced32efb.tar.gz
gentoo-66316ff45e6df5c0399fafeb7685188fced32efb.tar.bz2
gentoo-66316ff45e6df5c0399fafeb7685188fced32efb.zip
dev-python/rtimulib: add python3.7 support.
Also bumped to EAPI=7 and updated metadata.xml. Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10274 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/rtimulib')
-rw-r--r--dev-python/rtimulib/metadata.xml10
-rw-r--r--dev-python/rtimulib/rtimulib-7.2.1-r1.ebuild22
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/rtimulib/metadata.xml b/dev-python/rtimulib/metadata.xml
index 54d5423c4060..f9570ce600ab 100644
--- a/dev-python/rtimulib/metadata.xml
+++ b/dev-python/rtimulib/metadata.xml
@@ -9,4 +9,14 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <longdescription>
+ RTIMULib is the simplest way to connect a 9-dof, 10-dof or 11-dof IMU
+ to an embedded Linux system and obtain Kalman-filtered quaternion or
+ Euler angle pose data. Basically, two simple funtion calls
+ (IMUInit() and IMURead()) are pretty much all that's needed to integrate RTIMULib.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/RPi-Distro/RTIMULib/issues</bugs-to>
+ <remote-id type="github">RPi-Distro/RTIMULib</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-python/rtimulib/rtimulib-7.2.1-r1.ebuild b/dev-python/rtimulib/rtimulib-7.2.1-r1.ebuild
new file mode 100644
index 000000000000..b593b7430083
--- /dev/null
+++ b/dev-python/rtimulib/rtimulib-7.2.1-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PN="RTIMULib"
+MY_P="${MY_PN}-${PV}"
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Binding for RTIMULib, a versatile IMU library"
+HOMEPAGE="https://github.com/RPi-Distro/RTIMULib"
+SRC_URI="https://github.com/RPi-Distro/${MY_PN}/archive/V${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}/Linux/python"