summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2023-01-27 12:02:24 +0100
committerJakov Smolić <jsmolic@gentoo.org>2023-01-27 12:07:28 +0100
commit1863d5b30160a7b46c7bb5dc4ea68df4e29cdf8d (patch)
tree2d6c64a7fa507ef727529cf7aa0372f62018f3e5 /sci-biology
parentsci-misc/flashdot: treeclean (diff)
downloadgentoo-1863d5b30160a7b46c7bb5dc4ea68df4e29cdf8d.tar.gz
gentoo-1863d5b30160a7b46c7bb5dc4ea68df4e29cdf8d.tar.bz2
gentoo-1863d5b30160a7b46c7bb5dc4ea68df4e29cdf8d.zip
sci-biology/phred: treeclean
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/phred/Manifest1
-rw-r--r--sci-biology/phred/files/phred-071220-fix-build-system.patch82
-rw-r--r--sci-biology/phred/files/phred-071220-fix-qa.patch36
-rw-r--r--sci-biology/phred/metadata.xml8
-rw-r--r--sci-biology/phred/phred-071220-r2.ebuild46
5 files changed, 0 insertions, 173 deletions
diff --git a/sci-biology/phred/Manifest b/sci-biology/phred/Manifest
deleted file mode 100644
index 1c0aa1a3ee91..000000000000
--- a/sci-biology/phred/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST phred-dist-071220.b-acd.tar.gz 357767 BLAKE2B ae1180f54eaa3631a4e32c2ffe388b35745302e3d014c8fa893119e7e488d4bb4316f7ee0588cd12db5cbbc23033f689f4a0a487cdc7fe42e8c7a67ceb3c43ae SHA512 0a6b0a733e6dcc0495eaab720b75f8e5815df494d0a773b8b8336d5208321c2ba475921084835a769367ec51aed156585ab97346a510100d4337e3215ec75276
diff --git a/sci-biology/phred/files/phred-071220-fix-build-system.patch b/sci-biology/phred/files/phred-071220-fix-build-system.patch
deleted file mode 100644
index 997f39941a07..000000000000
--- a/sci-biology/phred/files/phred-071220-fix-build-system.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-* Fix build system to honour CC, CFLAGS, CPPFLAGS and LDFLAGS
-* Specify a default target, in order to keep the ebuild slim
-
---- a/Makefile
-+++ b/Makefile
-@@ -12,9 +12,9 @@
-
- # UNIX specific definitions (default)
- #
--CC= cc
--CFLAGS= -O -DANSI_C $(LXFLAGS)
--CLIB= -lm
-+CC ?= cc
-+CPPFLAGS += -DANSI_C $(LXFLAGS)
-+LIBS += -lm
-
- # Windows 'nmake' specific definitions
- #
-@@ -133,9 +133,6 @@
- $(objdir)writeSDF.o \
- $(objdir)writeSeq.o
-
--SRCS = $(OBJS:.o=.c)
--WOBJ = $(OBJS:.o=.obj)
--
- INCS = \
- $(incdir)chromatData.h \
- $(incdir)freeChromatData.h \
-@@ -179,48 +176,18 @@
- # UNIX make specific phred target
- # note: a horizontal tab character must precede `$(CC)'
- #
--phred: $(OBJS)
-- $(CC) $(CFLAGS) -o phred $(OBJS) $(CLIB)
-
-
--# Windows nmake specific phred target
--#
--forwindows: $(WOBJ)
-- $(CC) $(CFLAGS) /Fephred $(WOBJ)
--# $(CC) $(CFLAGS) /Fedaev daev.c
-+.PHONY: all
-+all: phred daev
-
-
--# test CC: refuse to compile if
--#
--# o SunOS
--#
--# AND
--#
--# o using /usr/ucb/cc compiler
--#
--# NOTE: this compiler causes problems: see PHRED.DOC
--#
--test_cc:
-- @if [ `uname` = SunOS ] ; \
-- then \
-- if [ `which $(CC)` = "/usr/ucb/cc" ] ; \
-- then \
-- echo ""; \
-- echo "============================================================"; \
-- echo "| |"; \
-- echo "| This SUN C compiler produces a bad phred executable. |"; \
-- echo "| |"; \
-- echo "| Please see the PHRED.DOC file for more information. |"; \
-- echo "| |"; \
-- echo "============================================================"; \
-- echo ""; \
-- exit 1; \
-- fi \
-- fi
-+phred: $(OBJS)
-+ $(CC) $(LDFLAGS) $(CFLAGS) -o phred $^ $(LIBS)
-
-
- daev: daev.o
-- $(CC) $(CFLAGS) -o daev daev.o -lm
-+ $(CC) $(LDFLAGS) $(CFLAGS) -o daev $^ $(LIBS)
-
-
- clean:
diff --git a/sci-biology/phred/files/phred-071220-fix-qa.patch b/sci-biology/phred/files/phred-071220-fix-qa.patch
deleted file mode 100644
index ab4d2ea023f6..000000000000
--- a/sci-biology/phred/files/phred-071220-fix-qa.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Fix implicit declarations:
-* daev.c: In function ‘processParameters’:
-* daev.c:849:14: warning: implicit declaration of function ‘isdigit’ [-Wimplicit-function-declaration]
-* if( !isdigit( argv[iarg][0] ) )
-
---- a/autoPhred.c
-+++ b/autoPhred.c
-@@ -57,6 +57,7 @@
- static int xstrcmp();
- #endif
-
-+int freeMBRData( MBRData *mbrData );
- #ifdef ANSI_C
- int autoPhred( Option *option )
- #else
---- a/daev.c
-+++ b/daev.c
-@@ -58,6 +58,7 @@
- #include <sys/stat.h>
- #include <time.h>
- #include <math.h>
-+#include <ctype.h>
-
- #ifndef _WIN32
- #include <dirent.h>
---- a/mergedBaseRead.c
-+++ b/mergedBaseRead.c
-@@ -63,7 +63,7 @@
- Peak *peak;
- Observed_peak *obs_peak;
-
-- static initFlag = 0;
-+ static int initFlag = 0;
- static char mchar[256][256];
-
- if( initFlag == 0 )
diff --git a/sci-biology/phred/metadata.xml b/sci-biology/phred/metadata.xml
deleted file mode 100644
index ccdff086e20b..000000000000
--- a/sci-biology/phred/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci-biology@gentoo.org</email>
- <name>Gentoo Biology Project</name>
- </maintainer>
-</pkgmetadata>
diff --git a/sci-biology/phred/phred-071220-r2.ebuild b/sci-biology/phred/phred-071220-r2.ebuild
deleted file mode 100644
index 2d33df654a1b..000000000000
--- a/sci-biology/phred/phred-071220-r2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-DESCRIPTION="A base caller for Sanger DNA sequencing"
-HOMEPAGE="http://phrap.org/phredphrapconsed.html"
-SRC_URI="${PN}-dist-${PV}.b-acd.tar.gz"
-S="${WORKDIR}"
-
-LICENSE="phrap"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="fetch"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-071220-fix-build-system.patch
- "${FILESDIR}"/${PN}-071220-fix-qa.patch
-)
-
-pkg_nofetch() {
- einfo "Please visit ${HOMEPAGE} and obtain the file"
- einfo "${SRC_URI}, then place it into your DISTDIR directory."
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}"
-}
-
-src_install() {
- dobin phred daev
-
- insinto /usr/share/phred
- doins phredpar.dat
-
- newenvd - 99phred <<- EOF
- PHRED_PARAMETER_FILE="${EPREFIX}/usr/share/phred/phredpar.dat"
- EOF
-
- newdoc DAEV.DOC DAEV.DOC.txt
- newdoc PHRED.DOC PHRED.DOC.txt
-}