summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-02 23:33:11 +0100
committerSam James <sam@gentoo.org>2022-07-02 23:33:11 +0100
commit4e3464f740a62b786296d21274e6197b8f3a4bd0 (patch)
tree8d74664712d6c9d3f50a906fcdfd110680965d87 /sci-biology
parentnet-mail/mhonarc-gentoo: update EAPI 6 -> 8 (diff)
downloadgentoo-4e3464f740a62b786296d21274e6197b8f3a4bd0.tar.gz
gentoo-4e3464f740a62b786296d21274e6197b8f3a4bd0.tar.bz2
gentoo-4e3464f740a62b786296d21274e6197b8f3a4bd0.zip
sci-biology/vcftools: drop 0.1.14
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/vcftools/Manifest1
-rw-r--r--sci-biology/vcftools/files/vcftools-0.1.14-buildsystem.patch50
-rw-r--r--sci-biology/vcftools/vcftools-0.1.14.ebuild39
3 files changed, 0 insertions, 90 deletions
diff --git a/sci-biology/vcftools/Manifest b/sci-biology/vcftools/Manifest
index 411610b28376..36aa8e465e22 100644
--- a/sci-biology/vcftools/Manifest
+++ b/sci-biology/vcftools/Manifest
@@ -1,2 +1 @@
-DIST vcftools-0.1.14.tar.gz 342369 BLAKE2B 14be867c0be41767e2c97c8be212f3cff495c1cb6699294fb8a26ac491901599cd1e400cb80c6d609dce36584ee5defdb3b3652657bd127e0c67c5b29a842cc5 SHA512 863a16b3b20d392deba7f04310af95f1ab21be537273692aa104e22d737af2eb1bc54a768af954f06188e0500e4f7a032d1189886eb3a439b108cb8189b14eb7
DIST vcftools-0.1.16.tar.gz 480575 BLAKE2B 5c0bf67aef8ef4705f621485df4c556f6bace190311c308f0364f3e274cf4818f56f2186905fdfb7459dc4be9664a8b1ff631e2cecd03abd7aa82dcfc7e5aa64 SHA512 c4dd5ceb3ad0512e839154d8a05ef3e7a03cbe52c3099df48775b35460fce7ef10102819c2d1cefa33b98ad09e7bd1608e871978860ec9c0b0c2e781892b22e6
diff --git a/sci-biology/vcftools/files/vcftools-0.1.14-buildsystem.patch b/sci-biology/vcftools/files/vcftools-0.1.14-buildsystem.patch
deleted file mode 100644
index 126a709385db..000000000000
--- a/sci-biology/vcftools/files/vcftools-0.1.14-buildsystem.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-* Add prefix in Makefiles, not the configure script
-* Use AC_SEARCH_LIBS instead of AC_CHECK_LIB,
- as it is more flexible and helps us with LAPACK
-* Use correct ZLIB_CFLAGS instead of non-existent ZLIB_CPPFLAGS
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -34,7 +34,7 @@
- [--with-pmdir=DIR],
- [install Perl modules in DIR]),
- [PMDIR=${withval}],
-- [PMDIR='${prefix}'/"$pmdir_relative_path"])
-+ [PMDIR="$pmdir_relative_path"])
-
- AC_SUBST([PMDIR])
-
-@@ -73,9 +73,9 @@
- [pca=${enableval}],
- [pca=no])
-
--if test "x${pca}" = "xyes" ; then
-- AC_CHECK_LIB(lapack, dgeev_)
--fi
-+AS_IF([test "x${pca}" = "xyes"],[
-+ AC_SEARCH_LIBS([dgeev_], [lapack])
-+])
-
- # Generate output.
- AC_CONFIG_FILES([Makefile
---- a/src/cpp/Makefile.am
-+++ b/src/cpp/Makefile.am
-@@ -1,6 +1,6 @@
- bin_PROGRAMS = vcftools
-
--vcftools_CPPFLAGS = $(ZLIB_CPPFLAGS)
-+vcftools_CPPFLAGS = $(ZLIB_CFLAGS)
- vcftools_LDADD = $(ZLIB_LIBS)
-
- vcftools_SOURCES = \
---- a/src/perl/Makefile.am
-+++ b/src/perl/Makefile.am
-@@ -24,7 +24,7 @@
- vcf-tstv \
- vcf-validator
-
--pmdir = $(PMDIR)
-+pmdir = $(exec_prefix)/$(PMDIR)
-
- dist_pm_DATA = \
- FaSlice.pm \
diff --git a/sci-biology/vcftools/vcftools-0.1.14.ebuild b/sci-biology/vcftools/vcftools-0.1.14.ebuild
deleted file mode 100644
index 7b386453ae25..000000000000
--- a/sci-biology/vcftools/vcftools-0.1.14.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools flag-o-matic perl-functions toolchain-funcs
-
-DESCRIPTION="Tools for working with VCF (Variant Call Format) files"
-HOMEPAGE="http://vcftools.sourceforge.net/"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="lapack"
-
-RDEPEND="sys-libs/zlib
- dev-lang/perl:=
- lapack? ( virtual/lapack )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-PATCHES=( "${FILESDIR}/${PN}-0.1.14-buildsystem.patch" )
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- perl_set_version
-
- append-flags $($(tc-getPKG_CONFIG) --cflags lapack)
- append-libs $($(tc-getPKG_CONFIG) --libs lapack)
-
- econf \
- $(use_enable lapack pca) \
- --with-pmdir="${VENDOR_LIB#${EPREFIX}/usr}"
-}