summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-29 09:47:41 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-29 09:47:41 +0100
commit8e283ddd7e7cfd33203278872556a5b7db34eaa1 (patch)
tree6b80232419e4f093c535c06d5551ed57b3035872 /sys-libs
parentdev-python/lxml: Bump to 4.4.3 (diff)
downloadgentoo-8e283ddd7e7cfd33203278872556a5b7db34eaa1.tar.gz
gentoo-8e283ddd7e7cfd33203278872556a5b7db34eaa1.tar.bz2
gentoo-8e283ddd7e7cfd33203278872556a5b7db34eaa1.zip
sys-libs/compiler-rt: Fix stripping -nodefaultlibs
Closes: https://bugs.gentoo.org/706266 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild2
-rw-r--r--sys-libs/compiler-rt/compiler-rt-11.0.0.9999.ebuild2
-rw-r--r--sys-libs/compiler-rt/compiler-rt-7.1.0.ebuild2
-rw-r--r--sys-libs/compiler-rt/compiler-rt-8.0.1.ebuild2
-rw-r--r--sys-libs/compiler-rt/compiler-rt-9.0.1.ebuild2
5 files changed, 5 insertions, 5 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
index b5eea1980e7d..fb90bbaab7cf 100644
--- a/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
@@ -62,9 +62,9 @@ src_configure() {
if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++
+ strip-unsupported-flags
# ensure we can use clang before installing compiler-rt
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
- strip-unsupported-flags
elif ! test_compiler; then
if test_compiler "${nolib_flags[@]}"; then
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
diff --git a/sys-libs/compiler-rt/compiler-rt-11.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-11.0.0.9999.ebuild
index b5eea1980e7d..fb90bbaab7cf 100644
--- a/sys-libs/compiler-rt/compiler-rt-11.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-11.0.0.9999.ebuild
@@ -62,9 +62,9 @@ src_configure() {
if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++
+ strip-unsupported-flags
# ensure we can use clang before installing compiler-rt
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
- strip-unsupported-flags
elif ! test_compiler; then
if test_compiler "${nolib_flags[@]}"; then
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
diff --git a/sys-libs/compiler-rt/compiler-rt-7.1.0.ebuild b/sys-libs/compiler-rt/compiler-rt-7.1.0.ebuild
index 8339d3420ba3..1962c02d2f22 100644
--- a/sys-libs/compiler-rt/compiler-rt-7.1.0.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-7.1.0.ebuild
@@ -66,9 +66,9 @@ src_configure() {
if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++
+ strip-unsupported-flags
# ensure we can use clang before installing compiler-rt
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
- strip-unsupported-flags
elif ! test_compiler; then
if test_compiler "${nolib_flags[@]}"; then
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
diff --git a/sys-libs/compiler-rt/compiler-rt-8.0.1.ebuild b/sys-libs/compiler-rt/compiler-rt-8.0.1.ebuild
index 5049bf3761b8..403e394f7446 100644
--- a/sys-libs/compiler-rt/compiler-rt-8.0.1.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-8.0.1.ebuild
@@ -67,9 +67,9 @@ src_configure() {
if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++
+ strip-unsupported-flags
# ensure we can use clang before installing compiler-rt
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
- strip-unsupported-flags
elif ! test_compiler; then
if test_compiler "${nolib_flags[@]}"; then
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
diff --git a/sys-libs/compiler-rt/compiler-rt-9.0.1.ebuild b/sys-libs/compiler-rt/compiler-rt-9.0.1.ebuild
index af2de6ee54e0..f5ce47c037e8 100644
--- a/sys-libs/compiler-rt/compiler-rt-9.0.1.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-9.0.1.ebuild
@@ -62,9 +62,9 @@ src_configure() {
if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++
+ strip-unsupported-flags
# ensure we can use clang before installing compiler-rt
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
- strip-unsupported-flags
elif ! test_compiler; then
if test_compiler "${nolib_flags[@]}"; then
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"