summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-03-30 17:42:31 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-03-30 17:43:01 +0200
commitad207c941c2cebd1b5051ac7ad00e511ecdd7ef0 (patch)
tree36a2580235023330a5874da447c2815cff353109 /www-client
parentwww-client/firefox: don't install -x11 shortcut/.desktop file when not needed (diff)
downloadgentoo-ad207c941c2cebd1b5051ac7ad00e511ecdd7ef0.tar.gz
gentoo-ad207c941c2cebd1b5051ac7ad00e511ecdd7ef0.tar.bz2
gentoo-ad207c941c2cebd1b5051ac7ad00e511ecdd7ef0.zip
www-client/firefox-bin: don't install -x11 shortcut/.desktop file when not needed
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox-bin/firefox-bin-68.6.0-r1.ebuild11
-rw-r--r--www-client/firefox-bin/firefox-bin-74.0-r1.ebuild11
2 files changed, 14 insertions, 8 deletions
diff --git a/www-client/firefox-bin/firefox-bin-68.6.0-r1.ebuild b/www-client/firefox-bin/firefox-bin-68.6.0-r1.ebuild
index eb30ac30836f..77ed113988e8 100644
--- a/www-client/firefox-bin/firefox-bin-68.6.0-r1.ebuild
+++ b/www-client/firefox-bin/firefox-bin-68.6.0-r1.ebuild
@@ -161,11 +161,14 @@ src_install() {
newbin "${FILESDIR}"/firefox-bin-wayland.sh ${PN}-wayland
;;
X11)
- exec_command="${PN}-x11 --name ${PN}-x11"
- if use wayland ; then
- # Only needed when there's actually a choice
- newbin "${FILESDIR}"/firefox-bin-x11.sh ${PN}-x11
+ if ! use wayland ; then
+ # Exit loop here because there's no choice so
+ # we don't need wrapper/.desktop file for X11.
+ continue
fi
+
+ exec_command="${PN}-x11 --name ${PN}-x11"
+ newbin "${FILESDIR}"/firefox-bin-x11.sh ${PN}-x11
;;
*)
app_name="${name}"
diff --git a/www-client/firefox-bin/firefox-bin-74.0-r1.ebuild b/www-client/firefox-bin/firefox-bin-74.0-r1.ebuild
index f8f296dafd15..85a96b9928c8 100644
--- a/www-client/firefox-bin/firefox-bin-74.0-r1.ebuild
+++ b/www-client/firefox-bin/firefox-bin-74.0-r1.ebuild
@@ -161,11 +161,14 @@ src_install() {
newbin "${FILESDIR}"/firefox-bin-wayland.sh ${PN}-wayland
;;
X11)
- exec_command="${PN}-x11 --name ${PN}-x11"
- if use wayland ; then
- # Only needed when there's actually a choice
- newbin "${FILESDIR}"/firefox-bin-x11.sh ${PN}-x11
+ if ! use wayland ; then
+ # Exit loop here because there's no choice so
+ # we don't need wrapper/.desktop file for X11.
+ continue
fi
+
+ exec_command="${PN}-x11 --name ${PN}-x11"
+ newbin "${FILESDIR}"/firefox-bin-x11.sh ${PN}-x11
;;
*)
app_name="${name}"